headache: Ruby corrupt on mac os x

Somehow rails stopped working so I was trying to reinstall it, but I got this error: ERROR: The provided CC(/usr/bin/gcc) is LLVM based, it is not yet fully supported by ruby and gems, please read rvm requirements. Found this post: http://stackoverflow.com/questions/8000145/ruby-rvm-llvm-and-mysql Did rvm get head rvm install That fixed my problem